Avatar uživatele
pudyhady

V Excelu dělím číslo 2345/6 a vyjde 123 hodnota bude SPRÁVNĚ když by vyšlo 123,4 je hodnota ŠPATNĚ jakou funkci použít

Doplňuji:
No je to trochu složitější 2345 se bude měnit 6 zůstane stejná tedy když 2345 je dělitelné 6 beze zbytku je výsledek SPRÁVNĚ v opačném případě ŠPATNĚ.

Zajímavá 0 před 2729 dny Sledovat Nahlásit



Odpovědi
Avatar uživatele
l564

Podmínku neboli, funkci KDYŽ

0 Nominace Nahlásit

Avatar uživatele
Dochy

Pokud Tě zajímá dělitelnost dvou čísel, pak nejlépe asi:
=KDYŽ(MOD(A1;A2)=0;"SPRAVNE";" SPATNE")
MOD je zbytek po celočíselném dělení

0 Nominace Nahlásit

Avatar uživatele
RedC22

Napadly mě dvě možnosti (A1=2345, B1=19):
=ZAOKR.DOLŮ(A1/B1;1)
=(A1-MOD(A1;B1))/B1
Když jsem googlil nějakou elegantnější fci, tak jsem našel jen něco takovýho: =USEKNOUT(A1/B1)

Mimochodem 2345/6 není 123,4.

0 Nominace Nahlásit

Avatar uživatele
chudst

=KDYŽ(A1=123;"SPRÁVNĚ";KDYŽ(A1 =123, 4;"ŠPATNĚ";"Vyšel jiný výsledek"))
Doplňuji:
A1 nahraďte buňkou, kde byl výsledek. Pokud jste myslel, když vyjde jakékoli jiné číslo, než je 123, pak je to jednodušší:

=KDYŽ(A1=123;"SPRÁVNĚ";"ŠPATNĚ ")

Upravil/a: chudst

0 Nominace Nahlásit

Diskuze k otázce
Avatar uživatele
pudyhady

Dochy:
díky ale teď mám jiný problém použil jsem tedy tvoji funkci a zapsal ji takto
=KDYŽ(MOD(ČÁST(D4;1;6)&ČÁST(D4 ;8;4);6)=0;"špatné";"správné")
ČÁST je použita protože číslo v D4 vypadá takto 123456&1234 ten symbol tam být musí a dělění číslo má vypadat takto 1234561234 ale hodí mi to chybu #NUM!

před 2729 dny Odpovědět Nahlásit
Nový příspěvek
Zajímavé otázky v kategorii Počítače a internet