Avatar uživatele
Pokročilý

Jak nainstalovat Adobe Flash Player do Linuxu?

Dobrý den,

stáhla jsem si tři balíky Adobe Flash Player pro Linux (ze stránek adobe) a ani jeden nejde nainstalovat. Tak jsem to zkoušela přes terminál příkazem sudo apt-get install flashplugin-nonfree. Bohužel ani tohle nefunguje. Objevuje se mi toto: http://www.imgup.cz/… - nakonci je, že Balík "flashplugin-nonfree" nemá kandidáta pro instalaci. Pak jsem našla, že mám rozbalit soubor s příponou .tar.gz a zkopírovat soubory do složky /home/uživatel/. mozilla/plugins, ale to také nefunguje.

Prosím, nevíte někdo co s tím? Už toho mám plné zuby. Používám pořád Windows a ségra má teď Linux a prostě to nejde a už mě to štve. Děkuji.

------

stáhla jsem všechny tři soubory, které mi to nabízelo a ani jeden nejde nainstalovat. Proklikala jsem soubor s koncovkou .rpm a vyskytla se chyba viz. v pravo dole: http://www.imgup.cz/…. Zkusila jsem instalaci přes terminal. Navedla jsem ho do složky stažené soubory, nefungovalo. Zkopírovala jsem soubor na plochu - nefungovalo (více v obrázku terminalu). Prostě nic z toho nefunguje a já nevím proč!

Uzamčená otázka – ohodnoťte nejlepší odpověď symbolem palce.

Nejlepší odpověď

Avatar uživatele
Bronzový

Problém plyne z nepochopení distribuce sw v Linuxu...

Jdi sem: https://get.adobe.com/…

Pozná to, že máš Linux. Vybereš si jakou distribuci (třeba Ubuntu - nevím co používáš) a podle toho obdržíš balíček (v případě ubuntu to bude něco jako *.deb). Pokud nevíš co máš zvolit stáhni něco jako *.rpm. Zkus to normálně "rozkliknout" a měl by se ti spustit nějaký správce balíků, kterým když se proklikáš tak se to nainstaluje.

Pokud to z nějakého důvodu chceš dělat z konzole pak napiš:
sudo apt-get install cesta k baliku
takže třeba
sudo apt-get install /home/nikola/Downloads/balik. rpm

To sudo je tam proto, že musíš být správce (root). Pokud jsi jako root přihlášená, tak tam být nemusí.

---

Vyřešeno:

V Ubuntu 12.10 nebo odvozených distribucích řeší příkaz
sudo apt-get install flashplugin-installer gsfonts-x11

Pokud se bude příště někdo na něco ptát prosím napište rovnou verzi distribuce, co používáte.

 

Otázka nemá žádné další odpovědi.

Diskuze k otázce

Avatar uživatele
Zlatý

arygnoc

úžasné, ako vie vaša diskusia odradiť normálneho človeka od vynikajúceho linuxu.

hm.

;-)

Avatar uživatele
Pokročilý

nikolqa.o

Nabízelo mi to ke stažení 4 soubory http://www.imgup.cz/…, ale pouze první tři šli stáhnout. Ten poslední soubor Flash Player 11.2 for Ubuntu (apt) stáhnout nejde. Objevuje se Adresa nebyla rozpoznána.

Avatar uživatele
Bronzový

jpau

Ok, co je to za distribuci? Vypadá to trochu jako PCLinuxOS, Q4OS nebo tak něco...

Co se stane když zkusíš ten rpm balíček rozkliknout? Měl by se pustit nějaký správce balíků...

Avatar uživatele
Pokročilý

nikolqa.o

Otevře se složka, kde mohu proklikávat soubor a teď zjišťuji, že nahoře vedle názvu je v hranatých závorkách Jen pro čtení.

Avatar uživatele
Bronzový

jpau

Pokud se chceš dopracovat k řešení tak mi odpovídej na věci, na které se ptám ;-).

1. Jak jsem se již ptal, CO JE TO ZA DISTRIBUCI? ("Ten Linux" se nějak jmenuje - pokud mi to řekneš dovedu zvolit konkrétní postup)
2. Není to co se ti otevřelo náhodou správce archivů?

Avatar uživatele
Pokročilý

nikolqa.o

Nevím, jestli je to ono, ale po zadání do terminalu cat /etc/issue to vypsalo Ubuntu 12.10 \n \l. A ano, otevřelo se to ve správci archivů.

Avatar uživatele
Pokročilý

nikolqa.o

Ještě jsem toho našla víc. Po napsání cat /etc/*-release vypsáno:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.10
DISTRIB_CODENAME=quantal
DISTRIB_DESCRIPTION="Ubuntu 12.10"
NAME="Ubuntu"
VERSION="12.10, Quantal Quetzal"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu quantal (12.10)"
VERSION_ID="12.10"

Avatar uživatele
Bronzový

jpau

Ubnut stačí, jde o to že máš debian like distribuci - proto budeme pracovat s deb, který Debian nativní. Btw zkus rozkiliknout ten *.deb + můj předchozí příspěvek.

Avatar uživatele
Bronzový

jpau

Ok, zkus:
sudo gdebi *.deb

Kde *.deb absolutní název (vč. cesty) toho deb balíku.

Máš tam aplikaci Synaptic?

Avatar uživatele
Pokročilý

nikolqa.o

Mám správce balíků Synaptic

Avatar uživatele
Bronzový

jpau

No tak ten balík (*.deb) otevři v tom Synapticu. Půjde se k tomu proklikat od toho balíku. Buď tím rozkliknutím (měl by se pustit Synaptic) nebo když na něj klepneš pravým tlačítkem tak tam někde bude Synaptic. Když ne, tak ho spust z místa, odkud si ho našla, někde v něm je možnost hledat, tak vyhledej flash - třeba bude v repozitáři

Avatar uživatele
Pokročilý

nikolqa.o

Já tady nemám žádný soubor s koncovkou .deb

Avatar uživatele
Bronzový

jpau

Sry, flash to tam má jako apt, tak klikni na to apt.

Avatar uživatele
Bronzový

jpau

Myslím na stažený soubor *.apt - jen pro jistotu

Avatar uživatele
Pokročilý

nikolqa.o

Jenže mě soubor s koncovkou .apt nejde ze stránek Adobe stáhnout. našítá se spouštění stahování a pak se objeví tohle http://www.imgup.cz/….

Avatar uživatele
Bronzový

jpau

Napiš do konzole toto:
sudo apt-get install flashplugin-installer gsfonts-x11

Avatar uživatele
Bronzový

jpau

OK, restart FireFoxu a pojďme to zkusit!

Avatar uživatele
Pokročilý

nikolqa.o

Restartovala jsem a stále ta samá chyba při stahování.

Avatar uživatele
Bronzový

jpau

Počkej, počkej řešíme flash. Teď by měl být nainstalovaný tak něco otevři, třeba youtube a zkus ho.

Avatar uživatele
Pokročilý

nikolqa.o

Pořád se mi objevuje jen nainstalujte Adobe Flash Player. Už mi to leze krkem. Já sem snad ségře nainstaluji starý windows XP. :D

Avatar uživatele
Bronzový

jpau

Zkus to chromium co tam máš.

Avatar uživatele
Pokročilý

nikolqa.o

Jo, tam už to funguje a dřív to taky nefungovalo. Tak že bude asi nějaká chyba v Mozalle. Děkuji moc.

Avatar uživatele
Bronzový

jpau

Možná to po restartu počítače bude fungovat i v tom FF. Pokud ne, tak si nainstaluj nové FF prostřednictvím toho Synapticu... Ubuntu 12.10 (což je základ Tvého distra) už je také poměrně staré (nyní Ubuntu 15.10)

Avatar uživatele
Pokročilý

nikolqa.o

Dobře, zkusím to zítra přeinstalovat, pokud to nepůjde. Ségra už mi notebook teď sebrala. Jinak jde to Ubuntu nějak jednoduše aktualizovat ? Já s tímhle systémem nemám vůbec žádné zkušenosti. Za mě zlaté Windows 10. :D I když je pravda, že jsem ve škole dělala ve Fedoře, ale ta vypadala jinak. :D

Avatar uživatele
Bronzový

jpau

Normálně jdi na stránky ubuntu:
http://www.ubuntu.cz/

Stáhni si iso obraz, vypal ho na cd/dvd, nainstaluj a užívej. Myslím že ty novější verze budou mít lepší integraci těchto věcí (flash, kodeky). Jinak distribucí je hromada, stačí se podívat na:
http://proc.linux.cz/

A vybrat si tu pravou. Já mám třeba rád openSuSE ale každému podle jeho gusta.

Avatar uživatele
Pokročilý

nikolqa.o

Děkuji. Kdybych chtěla Linux, tak jedině v podobě Fedory. Ale já jsem s tím svým Win10 spokojená. :)

 

Zajímavé otázky v kategorii Počítače a internet

Přihlásit se

Položte otázku, odpovězte, zapojte se, …

začněte zde

Reklama

Kvalitní odpovědi v: Počítače a internet

Zlatý Bedy 1525
Zlatý Michal Kole 1198
Zlatý mosoj 1028
Zlatý Hlada 949
Zlatý ge0rge 894
Zlatý www 829
Zlatý led 819
Zlatý badisko 818
Zlatý gecco 795
Zlatý arygnoc 674

Zobrazit celkový žebříček

Facebook

 

Váš požadavek se vyřizuje, počkejte prosím.