Avatar uživatele
Registrovaný

V Excelu dělím číslo 2345/6 a vyjde 123 hodnota bude SPRÁVNĚ když by vyšlo 123,4 je hodnota ŠPATNĚ jakou funkci použít

Doplňuji:
No je to trochu složitější 2345 se bude měnit 6 zůstane stejná tedy když 2345 je dělitelné 6 beze zbytku je výsledek SPRÁVNĚ v opačném případě ŠPATNĚ.

Odpovědi:

Avatar uživatele
Bronzový

Podmínku neboli, funkci KDYŽ


Avatar uživatele
Stříbrný

Pokud Tě zajímá dělitelnost dvou čísel, pak nejlépe asi:
=KDYŽ(MOD(A1;A2)=0;"SPRAVNE";" SPATNE")
MOD je zbytek po celočíselném dělení


Avatar uživatele
Pokročilý

Napadly mě dvě možnosti (A1=2345, B1=19):
=ZAOKR.DOLŮ(A1/B1;1)
=(A1-MOD(A1;B1))/B1
Když jsem googlil nějakou elegantnější fci, tak jsem našel jen něco takovýho: =USEKNOUT(A1/B1)

Mimochodem 2345/6 není 123,4.


Avatar uživatele
Zlatý

=KDYŽ(A1=123;"SPRÁVNĚ";KDYŽ(A1 =123, 4;"ŠPATNĚ";"Vyšel jiný výsledek"))
Doplňuji:
A1 nahraďte buňkou, kde byl výsledek. Pokud jste myslel, když vyjde jakékoli jiné číslo, než je 123, pak je to jednodušší:

=KDYŽ(A1=123;"SPRÁVNĚ";"ŠPATNĚ ")

 

Diskuze k otázce

Avatar uživatele
Registrovaný

pudyhady

Dochy:
díky ale teď mám jiný problém použil jsem tedy tvoji funkci a zapsal ji takto
=KDYŽ(MOD(ČÁST(D4;1;6)&ČÁST(D4 ;8;4);6)=0;"špatné";"správné")
ČÁST je použita protože číslo v D4 vypadá takto 123456&1234 ten symbol tam být musí a dělění číslo má vypadat takto 1234561234 ale hodí mi to chybu #NUM!

 

Zajímavé otázky v kategorii Počítače a internet

Přihlásit se

Položte otázku, odpovězte, zapojte se, …

začněte zde

Reklama

Kvalitní odpovědi v: Počítače a internet

Zlatý Bedy 1525
Zlatý Michal Kole 1198
Zlatý mosoj 1028
Zlatý Hlada 948
Zlatý ge0rge 894
Zlatý www 829
Zlatý led 820
Zlatý badisko 818
Zlatý gecco 795
Zlatý arygnoc 674

Zobrazit celkový žebříček

Facebook

 

Váš požadavek se vyřizuje, počkejte prosím.