Avatar uživatele
Pokročilý

Jak na podmíněné formátování v excelu?

Dobrý den poradí mi děkdo postup při podmíněném formátování v office 2010? příklad: potřebuji, aby se mi třeba v buňce B5 objevovalo číslo třeba 50 pokud je v buňce A1 hodnota třeba od 31 do 42. Nevím jak nastavit abych formát který chci v jedné buňce nastavit tak aby se odkazoval na podmínku v druhé buňce a jak toto nastavit děkuji
Doplňuji:
To: DOCHY - děkuji to mi pomohlo. Pokud budu potřebovat aby tedy v buňce B5 bylo 50 pokud je v buňce A1 hodnota od 31 do 42 tak už vím. Můžu nějak v zadané podmínce pokračovat tak, aby se v buňce B5 zobrazilo třeba 60 když v Buňce A1 bude hodnota od 43 do 50 atd... Prostě tu podmínku rozšířit? díky

Uzamčená otázka – ohodnoťte nejlepší odpověď symbolem palce.

Nejlepší odpověď

Avatar uživatele
Stříbrný

Není to formátování, je to funkce. V českém excelu je to B5=KDYŽ(A((A1>=31);(A1<=42));5 0;0)

Podmínka: Pokud v A1 je číslo větší nebo rovno 31 a menší nebo rovno 42
Pak v buňce má být 50,
jinak 0

 

Další odpovědi:

Avatar uživatele
Stříbrný

To co chceš, nelze realizovat podmíněným formátováním. To je určeno pouze ke změně formátu (barva, velikost, pozadí apod.) zobrazovaných dat v závislosti na vstupní hodnotě. Pro tvůj případ musíš použít funkce, napadá mě "IF", bohužel Excel nepoužívám, tak ti nemůžu napsat přesnou syntaxi.
Doplňuji:
Dochy má pravdu, v českém Excelu se ta fce jmenuje "KDYŽ". Zapomněl jsem, že dnes už se lokalizují i názvy fukkcí, ve starších verzích tomu tak nebylo, tam to bylo "IF".

 

Diskuze k otázce

Avatar uživatele
Stříbrný

Emefej

Ad doplnění, vetšina fcí se do sebe může vnořovat, takže to zkus, mělo by to jít.

Avatar uživatele
Stříbrný

Dochy

Přesně tak. Místo té poslední nuly v uvedeném vzorci zapíšeš znovu ten samý vzorec jen s upravenými hodnotami... takže pokud hodnota nebude mezi 31 a 42 bude se vyhodnocovat druhý vzorec.

Pokud by to ale mělo být výrazně složitější (třeba 20 hodnot pro 20 pásem) bylo by vhodnější například na druhém listě nadefinovat tabulku s mezema a hodnotama a ve tvé původní tabulce použít funkce pro vyhledání a dosazení hodnoty z té pomocné tabulky. Bylo by to pak přehlednější, opakovaně použitelné (pro další řádky) asnadno upravitelné jen úpravou té pomocné tabulky...

 

Zajímavé otázky v kategorii Počítače a internet

Přihlásit se

Položte otázku, odpovězte, zapojte se, …

začněte zde

Reklama

Kvalitní odpovědi v: Počítače a internet

Zlatý Bedy 1525
Zlatý Michal Kole 1198
Zlatý mosoj 1028
Zlatý Hlada 949
Zlatý ge0rge 894
Zlatý www 829
Zlatý led 819
Zlatý badisko 818
Zlatý gecco 795
Zlatý arygnoc 674

Zobrazit celkový žebříček

Facebook

 

Váš požadavek se vyřizuje, počkejte prosím.