Avatar uživatele
Zlatý

Excel: Jak nejjednodušeji udělat následující...

Mám dva sloupce. V obou sloupcích mám jména, některá se nachází ve sloupci A i ve sloupci B, jiná jen v jednom z nich.

Potřebuju udělat následující:
1)Pokud jsou ve sloupci dvě nebo víc stejných jmen, tak ponechat jen jedno a zbytek shodných jmen smazat. Toto potřebuju provést v obou sloupcích.

2) Všechna jména, z levého sloupce (A), která už jsou ve sloupci pravém (B), tak z levého odstranit.

Uzamčená otázka – ohodnoťte nejlepší odpověď symbolem palce.

Nejlepší odpověď

Avatar uživatele
Zlatý

1) karta Data / Odebrat stejné (Pokračovat s aktuální oblastí)
2) přidal bych sloupec mezi, do něj bych dal vzorec založený na funkci svyhledat, vyfiltroval bych, kde bylo nalezeno a z prvního sloupce potom smazal hodnoty

 

Otázka nemá žádné další odpovědi.

Diskuze k otázce

Avatar uživatele
Zlatý

bolak

Alesh: 1) V kartě "data" nic takovýho nemám, mám excel 2003
2) Trošku upřesnit bys to nemohl? Já sem to přes to zkoušel, ale asi to neumím nebo sem prostě blbej. Hoď mi sem rovnou vzorec, ať sou to koláče bez práce :)

Avatar uživatele
Zlatý

Alesh

Ježíšmarjá, to je materiál! :-))
1) hledej odebrat stejné nebo odebrat duplicity, hledej šmudlo
2) sloupce A a B, mezi vložíš sloupec, tím pádem se z B stane C, do buňky B1 napiš vzorec =SVYHLEDAT(A2;C:C;1;0)

Avatar uživatele
Zlatý

bolak

Tak tu jedničku, tu sem si nakonec našel ve filtrech :) a tu dvojku, tak ta nefunguje, takže ti dám ještě jednu šanci :D

Avatar uživatele
Zlatý

bolak

dobrý, tak už sem to vyřešil :) měls to sice celý blbě, ale tvoje odpověď mě dovadle ke správnému řešení, takže zaslouží obdarovat ;)

Avatar uživatele
Zlatý

Alesh

kecy, už z té formulace (měls to sice celý blbě) je zjevné, že pěkně kecáš! :-)

Avatar uživatele
Zlatý

bolak

no tak celý ne :) ale já budu věřit tomu, že jsi mi to takhle špatně napsal úmyslně, abych se něčemu naučil :))

 

Přihlásit se

Položte otázku, odpovězte, zapojte se, …

začněte zde

Reklama

Kvalitní odpovědi v: Počítače a internet

Zlatý Bedy 1525
Zlatý Michal Kole 1198
Zlatý mosoj 1028
Zlatý Hlada 949
Zlatý ge0rge 894
Zlatý www 829
Zlatý led 819
Zlatý badisko 818
Zlatý gecco 795
Zlatý arygnoc 674

Zobrazit celkový žebříček

Facebook

 

Váš požadavek se vyřizuje, počkejte prosím.