Avatar uživatele
Zlatý

EXCEL: Funkce pro udání datumu poslední změny v buňce

Zapisuju si v různé dny v různou dobu do excelu, do sloupce A údaj (číslo) a potřebuju, aby v době zapsání toho čísla mi to do druhého sloupce, na stejný řádek (odobrně řečeno: "hned vedle") vyhodilo automaticky datum a čas, kdy jsem tam to číslo vkládal.

Příklad: do buňky A1 napíšu číslo 189 a do vedlejší buňky B1 mi to napíše 14.8.2012 a to datum už tam napořád zůstane. Změní se jenom v případě že do té buňky A1 napíšu jiné číslo.

Uzamčená otázka – ohodnoťte nejlepší odpověď symbolem palce.

Nejlepší odpověď

Avatar uživatele

Klikni pravým tlačítkem myši na záložku (karta dole) ve které chceš, aby to fungovalo a z kontextového menu vyber možnost "Zobrazit kód". Do bílého okna napravo nakopíruj tuto proceduru:

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Address = "$A$1" Then
Cells(1, 2) = Now
End If
If Target.Address = "$A$2" Then
Cells(2, 2) = Now
End If
End Sub
Pokud se změní hodnota v buňce A1 (A2), do buňky B1(B2) se automaticky vepíše datum a čas změny.
Chápeš to, že jo.

Doplňuji:
Nejjednodušší, ale máš jen datum, bez času.
Ještě si dej formát buněk. Klik pravým myčítkem na sloupec B a v kontextovém menu vyber "Formát buněk", v něhlém okně - karta - číslo a v něm druh "Datum" a vyber si jaké zobrazení chceš v pravém náhledu.

=KDYŽ(A1>0;DNES())

 

Otázka nemá žádné další odpovědi.

Diskuze k otázce

Avatar uživatele

anonym

do bunky C ► =KDYŽ(A1>0;NYNÍ()) a máš i čas. U buěk C si nastav - Formát buněk Karta číslo a vyber druh "Čas", vpravo si vyber z náhledů jaký zobrazení času ti vyhovuje.

Avatar uživatele
Zlatý

bolak

Tohle by možná šlo, ale bude to určitě fungovat? Nebudou problémy? Nerad bych, abych to nastavil u všech buňek a ono by mi to pak najednou změnilo všechy uložený datumy zničeho nic na aktuální.

Avatar uživatele
Zlatý

bolak

Hm, tak je to přesně jak sem říkal, to datum tam sice je, ale jakmile napíšu do sloupce další datum, tak se automaticky všechny předchozí datumy aktualizujou...

Avatar uživatele

anonym

=KDYŽ(A1>0;DNES()) ► tohle do buněk B

Avatar uživatele
Zlatý

bolak

česílko: nemůžu zobrazit kód, píše mi to eror..nejde to nějak jinak?

Avatar uživatele

anonym

no jo, máš 2003 a já 2007, použij to jednodušší

Avatar uživatele
Zlatý

bolak

jenže ty píšeš že ten jednodušší je jenom datum, já tam potřebuju hlavně čas..

průůůséééééér :)

Avatar uživatele

anonym

Tu proceduru vlož do "makra", jinak už nevím

Avatar uživatele
Zlatý

bolak

jenže ty píšeš že ten jednodušší je jenom datum, já tam potřebuju hlavně čas..

průůůséééééér :)

Avatar uživatele

anonym

aha

 

Zajímavé otázky v kategorii Počítače a internet

Přihlásit se

Položte otázku, odpovězte, zapojte se, …

začněte zde

Reklama

Kvalitní odpovědi v: Počítače a internet

Zlatý Bedy 1525
Zlatý Michal Kole 1198
Zlatý mosoj 1028
Zlatý Hlada 948
Zlatý ge0rge 894
Zlatý www 829
Zlatý led 820
Zlatý badisko 818
Zlatý gecco 795
Zlatý arygnoc 674

Zobrazit celkový žebříček

Facebook

 

Váš požadavek se vyřizuje, počkejte prosím.